2009-09-06

「perfect_ATI_Driver」自動安裝ATI Driver for jaunty i386

使用腳本自動安裝ATI官方最新版驅動程式,只能用在9.04的i386版,安裝過程中看一下,是否顯示卡不能使用Catalyst 9-4版後驅動程式,有問題請回報。
我從Catalyst 9-4 到 Catalyst 9-8都有用腳本安裝。

2009.9.15
腳本更新,現在有新版本可以直接安裝了,版號小於9-3的一樣無法在jaunty上使用,目前最新出到9-9了我以安裝完成。




下載並安裝驅動程式

Step1、建立一個檔案perfect_ATI_Driver
gedit perfect_ATI_Driver
copy and pass

#!/bin/bash
OSVER=`lsb_release -cs`
BIT=`getconf LONG_BIT`
echo welcome to perfect_ATI_Driver
echo -e "\t\tbyhepha"
echo "你的版本是 $OSVER $BIT 位元"
if [[ $OSVER != 'jaunty' && $BIT != "32" ]]; then
echo "你所安裝Ubuntu版本非「jaunty」無法使用"
echo
exit
fi
echo "你所要安裝的版本是"
read -p "請輸入主版號(假設要安裝版本為9-8即輸入9):" main_ver
read -p "請輸入副版號(假設要安裝版本為9-8即輸入8):" sub_ver
Full_Ver=$main_ver-$sub_ver
if [[ $main_ver -le 9 && $sub_ver -le 3 ]]; then
echo 你所輸入的版號「$Full_Ver」無法使用需要大於「9-3」版
exit 0
else
echo -e "如你顯示卡在此清單之內將無法使用此驅動程式
9500 Series 9550 Series
9600 Series 9700 Series
9800 Series X300 Series
X550 Series X600 Series
X700 Series X800 Series
X850 Series X1050 Series
X1300 Series X1550 Series
X1600 Series X1650 Series
X1800 Series X1900 Series
Xpress Series X1200 Series
X1250 Series X2100 Series "
read -p "你的顯示卡是否不在清單之內(Y/N)?" -n1 yn
if [[ $yn = "y" || $yn = "Y" ]]; then
echo
echo 請看注意事項
echo "Resolved Issues
The following section provides a brief description of resolved issues with the latest version of the ATI CatalystTM Linux software suite. These include:
* With desktop effects enabled, transparent desktop no longer causes desktop icons and application windows to disappear
* Video playback no longer exhibits corruption when desktop effects are enabled and Composite is not explicitly disabled
* [Ubuntu 8.10] System now functions properly when starting X on surround view systems
* Resizing DVD playback window on Mplayer no longer causes blank video
* System instability no longer occurring when switching to full screen DVD playback with Totem Player
* Terminal window no longer displays error message when launching Catalyst Control Center in MultiView
* [Ubuntu 9.04] Xserver now starts properly with HD 4870 GPU configurations
* [Ubuntu 9.04] When xrandr --prop is evoked, Xserver failure no longer occurs under various system configurations
* The engine clock and memory clock values are now reported properly by ATI CAL"
else
echo 顯示卡在清單之內無法正常使用
exit 0
fi

read -p "你是否要開始安裝$Full_Ver版本? (Y/N) " -n1 yn
if [[ "$yn" = "y" || "$yn" = "Y" ]] ; then
sudo aptitude install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++5 dkms -y
cd /tmp
wget -c "www2.ati.com/drivers/linux/ati-driver-installer-$Full_Ver-x86.x86_64.run"
chmod +x ati-driver-installer-$Full_Ver-x86.x86_64.run
./ati-driver-installer-$Full_Ver-x86.x86_64.run --buildpkg Ubuntu/jaunty
sudo dpkg -i xorg-driver-fglrx_*.deb fglrx-kernel-source_*.deb fglrx-amdcccle_*.deb
sudo aticonfig --initial -f
fi
fi

Step2、給予執行權限並執行
chmod +x perfect_ATI_Driver && ./perfect_ATI_Driver

以下圖片是安裝畫面




更新的驅動程式

如有新版驅動程式,只需要修改腳本即可。
搜尋

if [[ "$Drvier" = "9-4" || "$Drvier" = "9-5" || "$Drvier" = "9-6" || "$Drvier" = "9-7" || "$Drvier" = "9-8" ]]; then

如是9-9版在其內新增 || "$Drvier" = "9-9",修改為
if [[ "$Drvier" = "9-4" || "$Drvier" = "9-5" || "$Drvier" = "9-6" || "$Drvier" = "9-7" || "$Drvier" = "9-8" || "$Drvier" = "9-9" ]]; then
注意 ||前面要留空格, "]]前面也要留空格。


參考資料:
Ubuntu Jaunty Installation Guide - cchtml.com