2009-09-25

「手把手」jaunty 核心升級到2.6.30含小測心得

今天看到ubuntu 9.04可以簡單改用2.6.30核心忍不住又給他升級一下了,前陣子我也有試過,那時要使用compiz的功能及3D還有音效通通掛點,我的顯示卡是Ati 4670要在2.6.30上使用還要打補丁,笨笨的我打上去也不行用。

還有想要穩定使用Ext4的機會也沒有(嘆氣),我核心是2.6.29使用時一直當(冒似人品不好),別人就能穩定使用(唉)。

剛升級之後除了Ext4還沒試驗外(給我勇氣吧!),其它使用都還蠻正常的,有興趣可以試試看嚕,不穩定在把核心K掉就好了。



安裝2.6.30 版核心
Step1、增加套件來源,更新套件庫,安裝新核心
OSVER=`lsb_release -cs`
echo "deb http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu $OSVER main"|sudo tee -a /etc/apt/sources.list
sudo aptitude update
sudo aptitude install linux-headers-2.6.30-10-generic linux-image-2.6.30-10-generic


小測試
Step1、3D加速支援
glxinfo| grep "direct rendering"
direct rendering: Yes

Step2、目前ATI驅動程式版本
fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 4600 Series
OpenGL version string: 2.1.8918



VirtualBox的DKMS安裝
Step1、不知為啥VirtualBox為啥沒順便更新,開啟時出現錯誤,更新一下就好了。
sudo /etc/init.d/vboxdrv setup
* Stopping VirtualBox kernel module * done.
* Recompiling VirtualBox kernel module * done.
* Starting VirtualBox kernel module * done.




我ATI驅動程式用「perfect」自動安裝ATI Driver for jaunty i386●ATI_Driver安裝的,自產自銷一下嘿嘿。

參考資料:
ubuntu 9.04可以簡單改用2.6.30核心